
Sahalie Software's
MAPI MESSAGE PAD CompuServe ID 73617,323
VERSION 4.0 Internet    sahalie@cyber-dyne.com

Overview

MAPI Message Pad is a telephone message system that supplements or replaces the traditional "While 
You Were Out" message pad.    

Message Pad utilizes the E-Mail services (MAPI) provided by Microsoft Windows® and Microsoft Mail  TM.
It requires a post office and user accounts created with either Microsoft Mail 3.x or the Mail application 
provided with Windows 95, Windows NT or Windows for Workgroups.    Because of its ability to access 
the accounts on your existing E-Mail system, Message Pad is very easy to install, use and maintain.    

Message Pad is tightly integrated with Windows E-Mail.    Messages sent with Message Pad appear in 
the Windows 95 and MS Mail Inbox and can be viewed either there or in Message Pad.    One 
advantage of this close integration is that you do not need to run Message Pad all of the time in order to 
be notified of new Message Pad messages.    If MS Mail or the Windows 95 InBox are active, they will 
trigger a dialog box which will notify you that you have received a new phone message. (Note: This 
feature is currently not enabled in Windows NT.    See Note to Windows NT Users below.)

A demo version of Message Pad is available as Shareware.    You can try it free for 30 days.    If you 
continue to use it, you must purchase it.    When you purchase Message Pad, you will receive disks with 
the registered version and a copy of the manual.    Message Pad is reasonably priced to provide value 
and to encourage registration.    Purchase information can be found at the end of this manual, and an 
order form (ORDER.RTF) is also included. 

Please note that features requiring database functions, including caller search and message logging, are
not enabled in the shareware version.    The additional database files required for these features would 
greatly increase the download size of the shareware version.    Message Pad uses the industry standard 
Microsoft Jet database engine, the same database that powers Microsoft Access™.    This means that 
the caller search and message log databases used by Message Pad can be accessed through Microsoft
Access for advanced searching, sorting and reporting.

New Features in Message Pad 4.0

• 32 Bit power for Windows 95 and Windows NT

• Improved message logging, with easy access to logged messages 
(registered version)

• Return receipts (registered version)

• Print list of all pending messages

• Windows 95 FaceLift

Other Great Features

• Recipient Lookup and PickList

• Message Forwarding

• Message Management with Follow-Up Checkboxes
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• Caller Search, which uses a database of previous callers to automatically fill in the caller's 
name, company and phone number.    Caller Search looks up matches as you type the caller's 
name. (registered version)

Installation

System Requirements

Message Pad requires a post office and user accounts created with MS Mail 3.x or the Mail 
application provided with Windows 95, Windows NT 3.51 or Windows for Workgroups.    
When you start Message Pad, it will automatically log on to your regular Exchange or MS 
Mail account.

MAPI Message Pad is available in 16 bit and 32 bit versions.    The 16 bit version is designed 
for Windows for Workgroups and Microsoft Mail 3.x.    The 32 bit version is designed for 
Windows 95 and Windows NT 3.51.    It is recommended that you have at least a 486 with 
16 megs of ram if you are using Windows 95 or Windows NT.    

To install Message Pad using the Setup program

In Windows 95:

• Insert Message Pad Disk 1 into drive A: or B:

• Click the Start button

• Select the Run… command

• In the Run dialog, type a:\setup.exe.    If the setup files are in another drive or directory,
substitute that drive or directory for a:\.

• Click OK and follow the on-screen instructions

In Windows for Workgroups or Windows NT 3.51:

• Insert Message Pad Disk 1 into drive A: or B:

• From Program Manager's File menu, choose Run.

• In the Command Line box, type a:\Setup.    

• Click OK and follow the on-screen instructions

Starting Message Pad

You can start Message Pad from its Program Manager icon or from Microsoft Mail.    There are two ways
to start Message Pad from Microsoft Mail:

• Select "Message Pad" from the “Compose” menu in the Windows 95 Inbox or the “Mail” menu in MS 
Mail.    This will start Message Pad or activate the current session if it is already running.    This menu 
item is added to MS Mail by Message Pad.    
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• Open a Message Pad message from MS Mail's InBox.    Message Pad messages can be identified in 
the Mail Inbox by the word "PHONE:" at the beginning of the subject line.    By default, Message Pad 
messages that are opened from Mail will be displayed in Message Pad.    This can be changed by 
selecting "Preferences" from the Options menu, and unchecking the check box labeled: "Launch 
Message Pad when message opened in Mail."

Note: You cannot start Message Pad from Microsoft Mail in Windows NT.    Instead, Message Pad
must be started from its Program Manager Icon in Windows NT.    See Note to Windows NT Users
below.

Sending Messages from Message Pad

To send a message

• Click the "Compose" button or choose "Compose Message" from the File menu.    This clears 
Message Pad and enters the current date and time.    

• Enter the name of the recipient of the message in the "To" box . 

• Enter the name and phone number of the caller and other pertinent information.    Press TAB to move 
the insertion point to the next box.    Press SHIFT-TAB to move to the previous text box.

• Click the "Send" button, choose "Send Message" from the File menu, or press CTL-S.

Recipient Pick List

Message Pad lets you create a pick list of people who are frequent message recipients.    Names can be
selected from the pick list by clicking the down arrow button next to the "To" box or by pressing the Down
Arrow key on your keyboard when the cursor is in the "To" box.    

The pick list is also used to autofill the "To" box.    As you type the recipient's name, Message Pad will 
check for matching names in the pick list and will automatically fill in the rest of the name for you.    

To modify the the pick list, select "Recipient Pick List" from the "Options" menu.    This will display the 
"Recipient List" dialog box, which allows you to add or remove names from the recipient pick list.    You 
can add names directly from your Mail Address Book by clicking the Address Book button in the 
"Recipient List" dialog.

The recipient pick list is maintained in a text file named RECIPS.LST in your Message Pad directory.

Verifying Recipient Mail Addresses

When you send a message, Message Pad automatically verifies the recipient's name.    If the name does
not match a valid user account, the message will not be sent.    If you entered a partial name, for 
instance the first name only, Message Pad will attempt to match that name with an existing account.    If 
the partial name matches more than one user account, you are presented with a list of matching names 
from which to choose.

Caller Search

Caller Search uses a database of previous callers to help you fill in the name, company and phone 
number of callers.    Caller Search is activated when you click the Compose button (or select New 
Message from the File menu), and it searches for matches as you type in the caller's name.    When the 
message is sent, Caller Search automatically updates its database.    
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Caller Search can be turned on or off by double clicking the “Caller Search” panel on the status bar.    In 
addition you can enable or disable Caller Search and select the Caller Search database by selecting 
“Data Options...” from the Tools menu

Caller Search is only available in the registered version of Message Pad.    Caller Search uses the 
Microsoft Jet 3.0 database engine, which is provided in the registered version of Message Pad.

Working With Messages You've Received

Message Pad checks your Mail account for new phone messages at the time interval specified in the 
Preferences dialog.    You can also direct Message Pad to check for new messages by clicking the "Get 
New" button or selecting "Get New Messages" from the File menu.

When new messages are received, they are listed in the Pending Messages listbox.    Unread messages
have a pink message slip icon.    Messages that have been read have a white message slip icon.    
Urgent messages are also preceded by an exclamation mark icon.

You can perform the following actions on received messages:

• Display the message - Select the message in the Pending Messages listbox

• Print the message - Display the message and click the "Print" button or choose "Print Message" from 
the File menu.    

• Print the Pending Messages list - To print all messages in the Pending Messages list, select “Print 
Pending Messages” from the File menu.

• Forward the message to another person - Display the message and click the "Forward" button.    Then
enter the mailbox name of the person to receive the message in the displayed dialog box.    Message 
Pad adds the text "Message Forwarded by [Your Name]" to the Note text box and sends the 
message.    It adds the text "Message Forwarded to [new recipient's name]" to your copy of the 
message.

• Delete the message from the Pending Messages listbox - Select the message in the "Pending 
Messages" listbox and click the "Delete" button or choose "Delete Message" from the File menu.    
Deleting a message also clears the message pad.

• Save changes to the message - Display the message and make the desired changes.    Choose 
"Save Message" from the File menu or click the "Save" button.

• Record Followup Activities    - Diplay the message and select the appropriate check marks under the 
"Follow-Up" heading, e.g. Returned Call, Left Message, etc.    The message is automatically saved 
whenever a Follow-Up checkmark is selected or unselected. 

Notification of New Messages

Message Pad checks your Mail account for new phone messages at the time interval specified in the 
Preferences dialog.    If    a new message is received while Message Pad is minimized, a dialog box pops
up over your current application to notify you that you have received a new message. 

If MS Mail is running, but Message Pad is not, you will be notified by a popup dialog box when new 
Message Pad messages are received by MS Mail. 
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Message Logging

Message Pad automatically logs all incoming and outgoing messages to a message log database.    You 
can disable message logging or change the name and directory of the message log database file by 
selecting "Data Options..." from the Tools menu, and clicking the “Message Logging” tab.

You can also disable or enable message logging by double clicking the ”Message Log” panel on the 
status bar.

Messages that you receive are logged when the message is first read in Message Pad.    Note that the 
message must be initially opened in Message Pad and not in MS Mail in order for the message to be 
added to the log file.

To view messages that have been logged by Message Pad, click the Message Log tab on the main 
screen.    All logged messages are displayed in reverse chronological order.    To view a particular 
message, click on that message.

Return Receipt

Message Pad provides return receipt capabilities when message logging is enabled.    To send a 
message with return receipt requested, check the Return Receipt Requested checkbox at the bottom of 
the message screen before sending the message.    When the message recipient opens the message, a 
return receipt message will be sent to your system.    Message Pad automatically processes the return 
receipt message.

To view all messages awaiting a return receipt message, click the Return Receipt tab on the main 
screen.    To display a message in the Return Receipt list, simply select the message.    To remove a 
message from the Return Receipt list, display the message and click the Ignore button next to the 
Return Receipt Requested checkbox.

Phone Dialer

If you have a modem with a phone connected to it, Message Pad can automatically dial the caller's 
number for you.    To dial a phone number, click the button with the telephone icon or select "Dialer" from 
the Options menu.    

Setting Message Pad Preferences

New Message preferences, default Action settings and Login/Delivery options can be changed in the 
Preferences dialog box.    The Preferences dialog box is displayed by selecting "Preferences" from the 
Tools menu.

Composing New Messages Tab

The default action settings are the Action checkboxes (i.e., Returned your call, Please Call, etc.) that are
automatically checked when you select Compose from the toolbar or the File menu.    The default Action 
settings can be changed in the Preferences dialog by selecting new actions and clicking OK.

Messages Tab

• In the "Check for new messages" box, type how often you want Message Pad to look for new phone 
messages.

• If you want Message Pad to notify you audibly when you receive a new phone message, select the 
"Sound chime" check box.
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• If your system has a sound card, you can enter a sound file to be played when a new message 
arrives.    A sample sound file called “newmsg.wav” is provided.

• If you want Message Pad to display a popup dialog box when you receive a new phone message, 
select the "Popup" check box.

• "Confirm before deleting messages" - If this box is checked, Message Pad will warn you before 
deleting a message.

• "Launch Message Pad when message opened in Mail" - Message Pad phone messages are listed in 
Microsoft Mail's Inbox.    If you want phone messages to be displayed by Message Pad when they are 
opened in MS Mail, select this checkbox.    If this box is not checked, phone messages will be 
displayed in Mail like any other message.

IMPORTANT If the Windows 95 Inbox or Microsoft Mail is running, changes to the "Launch 
Message Pad" setting do not take effect until you Exit and Restart MS Mail.

Logon/Delivery Tab

• Create New MAPI Session When Message Pad is Started

By default, Message Pad will use an existing MAPI session at startup.    If you have already opened the 
Windows 95 Inbox or MS Mail, Message Pad will not prompt you to re-enter your user name or password. 
However,in Windows 95 you have the option of creating multiple Exchange profiles using different E-Mail 
services.    If this checkbox is selected, Message Pad will always start a new MAPI session and will allow 
you to select which Profile to use.    

This feature is helpful if you have, for example, an Internet service provider that is accessed through the 
Windows 95 Inbox. When you select “Get Messages” from Message Pad’s File menu, it will attempt to 
logon to your Internet provider to force the download of messages, which is usually not desired.      One 
solution to this problem is to create an Exchange Profile that only includes the Microsoft Mail information 
service and does not include Internet services.      When you open Message Pad and are prompted to 
logon to Microsoft Exchange, select this Exchange profile.

To create a new profile using only the Microsoft Mail information service:

1. Click the Start button and select Settings/Control Panel
2. Double click on the Mail and Fax icon in Control Panel
3. In the MS Exchange Settings Properties dialog, click the Show Profiles button
4. In the MS Exchange Profiles dialog, click the Add button
5. This will open the Inbox Setup Wizard, which will prompt you to select the

information services to use.    Make sure that the only service that is checked is 
the Microsoft Mail service.    Then click the Next button.

6. Enter a name for the new profile.    Then click the Next button.
7. The Wizard will then take you through several additional steps, including

asking you to locate the workgroup post office and identify yourself in the
list of users.    Follow the onscreen instructions.    

• Force Delivery of Messages

If this checkbox is selected, Message Pad will force delivery of new messages from your Mail server 
when Message Pad is started and when the Get Messages button is clicked.    As discussed above, when 
Message Pad requests delivery of new messages from the MAPI mail system, it will attempt to get 
messages from all information service providers in the current Exchange profile.    If you do not want this 
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to occur and do not want to create a new Exchange Profile as discussed above, then uncheck this 
checkbox and Message Pad will not force delivery of new messages from your Mail server.

Notes to Windows NT Users

This version of MAPI Message Pad requires Windows NT 3.51.    All of the regular features of MAPI 
Message Pad are enabled in Windows NT, except for the following:

1. The Phone Dialer is not enabled in Windows NT.    Message Pad uses the phone dialer services 
provided by TAPI, Microsoft’s Telephony API.    Microsoft has not yet released TAPI libraries for 
Windows NT.      When those libraries are available, Message Pad will be able to utilize them.

2. Message Pad cannot communicate directly with the Mail client in Windows NT.      Therefore, we 
recommend that you leave Message Pad running all of the time in order to receive popup notification 
of new phone messages.    As a consequence of this limitation, there is no Message Pad item on the 
Compose menu.    In addition, when you open a phone message in the Windows NT Mail InBox, it 
does not launch Message Pad.      In addition, the Windows NT Mail client will not notify Message Pad 
of new phone messages when Message Pad is not running.    It is anticipated that this limitation will be
resolved in a forthcoming interim release of Message Pad.

Technical Support

Technical support is provided via CompuServe or Internet E-Mail.    Questions should be sent to 
CompuServe ID 73617,323 or via the Internet to sahalie@cyber-dyne.com.

Ordering Message Pad

A demo version of Message Pad is available as shareware.    You are licensed to use the shareware 
version for 30 days without charge.    If you continue to use it, you must purchase it.

Orders for Message Pad can be placed by completing the Order form (ORDER.RTF in your MSGPAD 
directory) and mailing it with payment or purchase order to: 

Sahalie Software
3320 Harris Street
Eugene, OR    97405

The license fee for Message Pad is based on the number of users, as follow:

5 users $60
10 users $100 

For more than 10 users, the license fee is $45 per every 5 users.    For licenses exceeding 25 users, 
please E-Mail a request for a corporate fee schedule to CompuServe ID 73617,323 or to sahalie@cyber-
dyne.com.
      
CREDIT CARD ORDERS can be placed through the Public Software Library by calling 800-242-4775 or 
713-524-6394 or by CIS EMail to 71355,470.    THESE NUMBERS ARE FOR ORDERS ONLY.    Any 
questions about the status of the shipment of the order, refunds, registration options, product details, 
technical support, volume discounts, dealer pricing, site licences, etc must be directed to Sahalie 
Software at the address listed above or by CIS E-Mail to 73617,323 or Internet E-Mail to sahalie@cyber-
dyne.com.
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5 User and 10 User Licenses for Message Pad can also be ordered through CompuServe's Software 
Registration Database (GO SWREG).        5 User License - ID 1541, 10 User License - ID 1544.

Registered sites receive the registered version on disk and a printed manual.    Registered Users recieve 
free upgrades for one year following registration.    Many thanks to those who have supported Message 
Pad by registering! 

© 1992-1996    Brian D. Stine.    All rights reserved.
Microsoft Windows, Microsoft Mail and Microsoft Access are trademarks of Microsoft Corp.
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